Eclectic Media Git rhapsode / master rhapsode.cabal
master

Tree @master (Download .tar.gz)

rhapsode.cabal @masterraw · history · blame

-- Initial rhapsode.cabal generated by cabal init.  For further 
-- documentation, see http://haskell.org/cabal/users-guide/

-- The name of the package.
name:                rhapsode

-- The package version.  See the Haskell package versioning policy (PVP) 
-- for standards guiding when and how versions should be incremented.
-- https://wiki.haskell.org/Package_versioning_policy
-- PVP summary:      +-+------- breaking API changes
--                   | | +----- non-breaking API additions
--                   | | | +--- code changes with no API change
version:             0.1.1.0

-- A short (one-line) description of the package.
synopsis:            Voice interface for The Web, encouraging universal accessibility.

-- A longer description of the package.
-- description:         

-- URL for the project homepage or repository.
homepage:            https://git.adrian.geek.nz/rhapsode

-- The license under which the package is released.
license:             GPL-3

-- The file containing the license text.
license-file:        LICENSE

-- The package author(s).
author:              Adrian Cochrane

-- An email address to which users can send suggestions, bug reports, and 
-- patches.
maintainer:          adrian@openwork.nz

-- A copyright notice.
-- copyright:           

category:            Web

build-type:          Simple

-- Extra files to be distributed with the package, such as examples or a 
-- README.
extra-source-files:  ChangeLog.md, README.md

-- Constraint on the version of Cabal needed to build this package.
cabal-version:       >=1.10


library
  -- .hs or .lhs file containing the Main module.
  exposed-modules: CExports, Input, Links, Render, Types
  
  -- Modules included in this library.
  other-modules:       SSML, SpeechStyle
  
  -- LANGUAGE extensions used by modules in this package.
  -- other-extensions:    
  
  -- Other library packages from which modules are imported.
  build-depends:       base >=4.9 && <=4.12, directory, bytestring,
        html-conduit, xml-conduit, text, containers, data-default-class,
        network-uri,
        stylist >= 2.2 && <3, css-syntax, xml-conduit-stylist >= 2.2 && <3, scientific,
        async, hurl >= 1.4.1.0, filepath, temporary,
        file-embed >= 0.0.9 && < 0.1
  
  -- Directories containing source files.
  hs-source-dirs:      src
  
  -- Base language which the package is written in.
  default-language:    Haskell2010
  
executable rhapsode
  main-is: main.c
  ghc-options: -no-hs-main
  extra-libraries: espeak-ng, sndfile
  build-depends:       base >=4.9 && <=4.12, rhapsode
  other-modules: Stub
  hs-source-dirs: src
  default-language: Haskell2010