Eclectic Media Git pingstats / f624f9d
Migrate to V1.0.1 - HOTFIX: Prevent crashing on asciiplotlib failure - Updates docs - Fixes setup.py crash due to version loading Ariana Giroux 7 months ago
4 changed file(s) with 15 addition(s) and 3 deletion(s). Raw diff Collapse all Expand all
198198 - Added tests for runtime and parser
199199 - Added test to ensure path is set properly f/ console scripts
200200 - (tag: V0.9.4) Moved custom_widget snippet to example file
201
202 **V1.0.0**
203
201204 - Pruned old hook files f/ git, unused and stale.
202205 - Updated the contribution guidelines
203206 - Made contribution guidelines more clear
207210 - Updated primary repo url throughout docs
208211 - Updated primary repo url throughout docs
209212 - Merge remote-tracking branch 'origin/googlegroups-bug-tracker'
210 - (origin/master, origin/HEAD) Fixed a hyperlink error in README.rst
213 - Fixed a hyperlink error in README.rst
211214 - Added import try/except block to handle missing gnuplot
212215 - Added multi-backend render functions
213216 - Makes UI Plot widgets intelligently choose backend
219222 - Updates sphinx-docs for V1.0, multi-backend support
220223 - Removed old screenshot, linked to demo
221224 - (tag: V1.0.0) Added link to readthedocs
225
226 **V1.0.1**
227
228 - Updated changelog f/ V1.0!
229 - HOTFIX: Fixes keyerror crash on asciiplotlib missing!
230 - Made setup non-reliant on package version variable
231 - Updates sphinx docs to reflect changes in V1.0.0
232 - Merge branch 'V1.0.1-docs-update'
233 - (V1.0.1) Merge branch 'V1.0.1-setup-fix'
3030
3131 from .config import get_lines, append_argv, parse_lines
3232
33 __version__ = "1.0.0"
33 __version__ = "1.0.1"
3434
3535 # RUN CONFIG
3636 if sys.argv[0].count('pingstats') and not sys.argv[0].count('.py'):
77
88 setup(
99 name='pingstats',
10 version='1.0.0',
10 version='1.0.1',
1111 description='Simple ping visualization on the CLI',
1212 long_description=long_description,
1313 long_description_content_type="text/x-rst",